Back to overview
Maintenance
Internet Upgrade/System Upgrade
Apr 23, 2026 at 5:00am UTC
–
Apr 24, 2026 at 5:59am UTC
Affected services
yourjockstraps.com
Resolved
Apr 24, 2026 at 5:59am UTC
Maintenance ended
Affected services
Created
Apr 23, 2026 at 5:00am UTC
The site will be down due to both updating the operating system running the site and also the ISP will also upgrade the network infrastructure that’ll cause temporary blackouts and make the site unavailable. Normally this should be completed during mid-day but expect to be fully completed at end of day.
Affected services